Missing People Results in SharePoint 2010 Beta

For those of you who have started playing with the SharePoint 2010 Beta, you may have noticed something wrong.  (Well, you may have noticed several things wrong, but I’m just referring to one of ‘em)  When you perform a people search, the peopleresults.aspx page is missing.

Real quick, I wanted to share with you what I did to remedy this situation.  I’m sure they’ll have this fixed by RTM, so don’t worry if it’s not perfect:

  1. Open your Search site in SharePoint Designer 2010.  The URL will be something like http://sitename.contoso.com/Search
  2. Click All Files on the left side of the screen.
  3. Copy the Results.aspx page, and paste a copy right there in the same folder.  Rename the copy to peopleresults.aspx.
  4. Browse to your new page in the browser.  Click the <Page> tab at the top, and click <Edit> at the top left to edit the page.
  5. On the left side of the page, delete the “Refinement” web part, and replace it with the “People Refinement” web part.
    Note that all of the Search web parts are grouped together under Search in the list of web parts to insert.
  6. Delete the Search Core Results web part, and replace it with the People Search Core Results one.
  7. In the top zone, replace the Search Box with the People Search Box. Done editing.

    I’ve also noticed that when I’m looking at tag profiles in SharePoint 2010, there’s a button in each tag page that says “View people who are following this tag”.  Notice that the URL for this link is under http://sitename.contoso.com/Search/Pages/Peopleresults.aspx.  This page needs to be created also.

  8. In SharePoint Designer, in All Files, right click and create a new folder.  Call this folder Pages.
  9. Copy the peopleresults.aspx file you just perfected AND the results.aspx, navigate to the new Pages folder, and simply paste them in there.

Again, maybe I’m missing something in the bigger picture as to why these pages didn’t exist, but this was just a little bug I came across today, and quickly fixed.  Enjoy.

 

Advertisements

4 comments

  • mattdemmy@msn.com

    Even better, go to Site Actions > Site Settings > Page layout and site templates and add the Enterprise Search Center or click Subsites can use any site template. Then create your new Search Center, delete the old “Search” and update the search settings on the portal and in My Site settings.

    Like

  • This is still broken for me in RTM and I don’t get the People Refinement nor any of the other people search web parts.

    Like

  • Alexey Krasheninnikov

    All I can tell is that this error doesn’t occur if you create the Enterprise Search Center as a root of site collection or as a subweb using newsbweb.aspx. This could be an error in some complex site definition provisioning procedure for things like Enterprise Publishing Portal.

    Like

  • good to know!

    Like

Leave a reply or question

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s