User Information within InfoPath Forms

There is a quick and easy way that information about the logged in user can be obtained from within an InfoPath form. You may have read my blog and other blogs before, with the user profile service web service instructions. In this post, I’m not going to be using the user profile service. This means that what I’m about to show you can be utilized with any version of SharePoint, whether you have a user profile service (enterprise) or not. This can be done with SharePoint 2010 Foundation, SharePoint 2010 enterprise and standard, and also WSS 3.0 and MOSS.

The User Information List is a list that exists at the site collection level, and contains a list of every user who has actually visited the SharePoint site. If they are a new user, they will not show in this list until they’ve actually visited a site in that site collection.

With that said, here are some instructions for getting some information about users, more specifically, the currently logged in user.

  1. Open up your InfoPath form, click on the Data tab, and click the Data Connections button.
  2. Click the Add… button.
  3. Choose Receive Data, and click Next.
  4. Choose SharePoint List or Library, and click Next.
    041212_0312_UserInforma1
  5. Paste the URL of your SharePoint site, click Next. (No need for any “default.aspx” at the end, or any other .aspx)
  6. Scroll down towards the bottom of the list of lists and libraries, and select User Information List. Click Next.
    (note that even though the user information list physically exists at the site collection level, you will still see this list on every sub-site also)
    041212_0312_UserInforma2
  7. Put check boxes next to the following fields, especially User_name. Click Next.
    041212_0312_UserInforma3
  8. Do not check the box to store a copy of the data. Click Next.
  9. This is very important. UNCHECK the box to automatically retrieve the data. Click Finish.
    041212_0312_UserInforma5
  10. On the Data Connections screen, click Close.
  11. Still on the Data tab in InfoPath, click the Form Load button, which will bring up the rules pane on the right side of the screen.
  12. Click the New button to create a new Action rule.
  13. Click the Add button and choose Set a Field’s Value. On the Rule Details screen, click the button next to Field.
  14. In the Fields drop-down box, choose User Information List, expand the queryFields, and select User name.
    (be sure that you’re selecting from the query fields, not the data fields.) Click OK.
    041212_0312_UserInforma6
  15. Back on the Rule Details screen, click the function (fx) button next to the Value box.
  16. Click the Insert Function button, and choose the userName function. Click OK two times.
    041212_0312_UserInforma7
  17. This is what your rule looks like. Click OK.
    041212_0312_UserInforma8
  18. Back over in the rules pane on the right, click the Add button, and choose Query for Data.
  19. Choose the User Information List and click OK.
    041212_0312_UserInforma9
  20. Now, each time the form is opened, the current user’s information will automatically be queried, and that one record will be retrieved. There are many ways that this information can be used within your form. The data exists in the data fields of the user information list. In the Fields pane on the right side of the screen, choose the User Information List from the drop-down box.
  21. Select the folder directly under dataFields, the one with the blue icon called d:SharePointListItem_RW. Drag it onto an empty area of your form, and when you let go, choose Repeating Section with Controls.
    I’m really just having you put all this on the form so that you can see exactly what’s being returned.
    041212_0312_UserInforma10
  22. Go ahead and publish the form, and open a new form. You’ll see all of the data about you will be displayed, something like this:
  23. One more little trick. Go back to InfoPath Designer. Delete the “Picture” field. Add a Picture control to the form (not a picture button, just a picture), and choose As a link. Click OK.
  24. You will be prompted to bind to a field. Select the Picture field under the User Information List data fields. Click OK.
    041212_0312_UserInforma12
  25. Filling out the form again, now there’s me:
    041212_0312_UserInforma13

    You can see how this data could potentially be used in many ways in your form. You can set some field defaults the first time the form is filled out, you could display the currently logged in user’s picture… You can even use formatting rules to show, hide, or disable certain fields depending on who the current user is or what department they’re in. I don’t usually drop the fields on the form like I showed you, that was for demonstration purposes. I usually just refer to that data via rules, etc. Keep in mind that the user information list does not have the 60 or so fields that the user profile service contains, but it is very useful nonetheless. There are many other blog posts out there that show how to tap into the user profile service using the web service in InfoPath, it’s just that if all you need is one of these basic fields, you might not need to deal with all of the complexity that it entails.

    Here are some other posts by me and others regarding user information in InfoPath:

84 comments

  • A novel approach when the User Profile Service is not an option…

    As always, another useful piece of InfoPath know how locked away in the armoury!

    Like

  • Thanks Laura! This article is great!

    Like

  • Great approach, Laura!

    Like

  • Laura, there are a few major concerns with the UIL:
    – It does not get updated when profile data changes in AD nor in the SharePoint Profile Database. Data only gets added once, and it stays there in a separate table of the Content Database named UserInfo
    – Likewise, every site collection has a different UIL, so one person’s data may be different in each site collection depending on when they were added, and the lists themselves won’t contain the same people
    – It does not contain all users. Users only get added to this list when explicitly reference in a Person/Group field like when adding permissions or assigning a task. Most people will not show up in the UIL usually.

    If the UIL would stay in sync with the identity provider and if it contained all people, then it would be great for this, especially for cases without UPS/UPA. You can consider a custom solution to keep it updated with all users, but then that would need to run for all site collections and would make the UserInfo table quite large.

    Like

  • Vikram Mulik(viks9884@yahoo.co.in)

    Laura as you hve told user information list physically exists at the site collection level, but we have to first create one custom list naming user information List right and after that when we open blank infopath form we will select data connection and follow the steps which you have done above.

    Like

  • Laura this looks great, my head is spinning with some potential uses for it.

    I am currently using your steps from the “Step by Step InfoPath and SharePoint” book in Chapter 9 to connect to the user profile service. I am using a people picker to gather the name and then gathering the email of that person. It’s working great when a single user is in the people picker. If I allow multiple people to be selected however I only return the first in the field. I tried changing my email field that captures the data to a repeating field but that didn’t yield any difference. Any thoughts on how to pull back multiple emails for the multiple names entered in my people picker?

    Any thoughts are greatly appreciated, your speaches, books and blog posts have saved my butt more times than I can count. 🙂

    Like

  • Vikram Mulik (viks9884@yahoo.co.in)

    Hey Laura we get the information of the user which is login that’s rite, but the information is gain itself by that user. If i am the admin of that site and i want to have information of user like how its show above displaying ur photo how will i get it . OR i have my own customer service desk site and i want my client or visitor to see my staff information in Infopath how will i achieve that.

    Like

  • Clayton,
    There’s a timer job that updates the user information lists so that they stay accurate when the user profile service does exist. This solution is mostly for people who don’t have the luxury of the UPS. I also already mentioned that people don’t exist in the list until they’ve actually visited the SharePoint site.

    Vikram,
    No, I’ve never had to create a custom list before performing these steps, it just always shows there no matter what site or subsite you’re on.

    Billie Jo,
    I can’t think of how you’d do that except to have 2 different fields and multiple text fields to put their email addresses in. Tricky.

    Vikram,
    At step 17 when you set a query field, you can set any of the query fields to anything. Be creative. If you set the Query field for Department to IT, then run the query, then what you’ll get is a big list of everyone in the IT department. Many examples. Just if you have 1,000’s of people in there I just don’t recommend ever querying the whole list without a specific query.

    Like

  • Laura,

    Is this possible to get SharePoint group for currently logged in user. I need to hide some of the fields for some group of users. now i am getting this data from one SharePoint list. That list contains login name and group name. Now i need to get the same from share point group. Is there any web services available for this… Please guide me… Thanks

    Like

  • Hi Laura,

    I’m using the information on chapter 9 of your book “Step-by-Step Using Microsoft InfoPath 2010 with Microsoft SharePoint 2010” to create forms that provide our users with a pre-populated form.

    We want users to open up a form and see that their first and last names are already included, along with their profile picture and email address. We only want users to submit their own forms, so we are not using the People Picker option.

    Everything works perfectly except for the very last part. When a user submits a form, the form is delivered to a SharePoint library. The people in charge of processing the submitted forms are opening them up and finding that the form is populated with their own information, not with the information of the user who submitted the form.

    I’m sure I’m missing a simple step somewhere… can you please let me know how to setup the form so that the pre-populated information of the user who filled it out is what shows up when the completed form is opened by a different user?

    Thank you,

    James

    P.S. By the way, the book is an excellent resource! I hope you get around to publishing a second one, with additional topics and features!

    Like

  • Hi Laura,

    Just wanted to follow-up on my question from yesterday (regarding the problem of the form being opened up by the people who process it, and finding that the pre-populated data on the form shows data on the people who are processing it, instead of data on the people who originally filled it out).

    The solution I found is this:

    Within the “Populate User Information” Form Load Rule, I set the Condition as follows:

    Attendee is blank

    That took care of the issue I was having. When the form is reviewed, it now opens up with the pre-populated information of the user that originally filled it out.

    I hope this is helpful to others.

    James

    Like

  • Arthra,
    Sorry I haven’t been able to find a good reliable no-code way to accomplish that.

    James,
    Cool, I’m glad you figured out the logic for that as a form load rule. 😉

    Like

  • Laura,
    Thank you so much! I am one of the cases that is unable to get my ups web services working correctly. This is a great workaround for me.

    Like

  • Could you use this for a SharePoint list as the first lookup?

    I’ve user in a list and I’d like to generate many of their userprofile fields based on the username in the first column.

    Like

  • Andrew,
    Yes, absolutely you can do it that way.

    Like

  • Hey Laura, something to add to this.

    If you publish to an Office365 Sharepoint, using Active Directory Federated services, you need to query based on Accountname = Username(); as the federated services add some prefixes to the username that do not work. Learned this the hard way, but your guide above helped me get the framework set up, just had to determine the alternate method to get populated data.

    Like

  • Hi Laura,

    Is it possible to populate the similar information for other users? In our case, we want users should have ability to select other users using people picker etc. and the other information should auto populate like Department, Work Phone.

    Like

  • Harpeet,
    Yes, it’s possible. Read my post on how to autopopulate the people picker. You have to create an extra field besides the people picker, call it something like EmployeeName. Set its default value as the AccountId field inside the people picker. Create an action rule based off of the EmployeeName field. Make this rule set the query field for the user profile service, and then do the query. Then you can set the values of all those other fields like department. Pretty tricky. Maybe I should write another post on that.

    Like

  • Hi Laura,

    It worked fine for admin users, but when I logged in with other users it is throwing an error stating:

    You do not have permissions to access a SharePoint list that contains data required for this form to function correctly.

    An entry has been added to the Windows event log of the server.
    Log ID:5566

    Correlation ID:ee505157-21d9-4a1e-804d-5f8dbe338d64

    Can you help me in this issue and tell me what may be the cause of this.

    Like

  • Hi Laura,
    Instead of using this information to set a field’s value, can you use it to switch views? So if UserName() is equal to xyz, switch to different view?

    Thank you!

    Like

  • Sameer,
    It sounds like those users don’t have access to the user information list. This is not normal behavior.

    Monique,
    Sure, you can do that via a form load rule. I usually just create a field called CurrentUser. On form load, set the value of CurrentUser to UserName(). Then do your condition if CurrentUser is so-and-so then switch views. Just remember it’s case sensitive.

    Like

  • Hello ,
    Congratulation for this article.
    That very very help me regarding
    error 5566
    that you say,

    9.This is very important. UNCHECK the box to automatically retrieve the data. Click Finish

    Thanks you !!!

    Like

  • Hi Laura, I realy appreciate this approach.

    However, I couldn’t make it work. I followed everything but not returning me any data, no error as well.

    Like

  • I really couldn’t get this working.
    I’m using infopath 2013 and sharepoint 2013. No error and no data returned as well.

    I’m Administrator of site collection.

    Hope you could help me fix this.

    Thanks in advance

    Like

  • Noel,
    Try using the user information list at the root site of the site collection.

    Like

  • Hi Laura,

    This is a great option for autopopulating user information. I’ve gotten it to work beautifully and pull the correct data when opening the form in infopath filler. However, when I publish the form to a S/P form library and then open the form in my browser (IE) the fields do not autopopulate; they are left blank. Any idea why it would be working in infopath filler and not in the browser?

    Thanks,
    Jennifer

    Like

  • Jennifer,
    I recommend troubleshooting this one. In InfoPath, in the fields pane on the right, change the drop-down to show your new data connection to the user info. Then, just drag that whole thing with all the fields onto the form. Create a button on your form and all it does is query that data connection. Then publish the form and see if any info is showing on your form, and try typing info in the query fields and clicking the query button to see if anything is coming in at all.

    Like

  • Thank you so much for posting this! I couldn’t find an alternative to the UPS anywhere but here and I’ve been searching for weeks.

    I would have much preferred to use the UPS, but SharePoint Online (Office 365) will not enable it.

    http://community.office365.com/en-us/forums/154/t/185751.aspx

    The only caveat for SharePoint online people was posted by Eric above (I ended up discovering this independently and came here to post it, but he beat me to it):

    Eric
    Hey Laura, something to add to this.

    If you publish to an Office365 Sharepoint, using Active Directory Federated services, you need to query based on Accountname = Username(); as the federated services add some prefixes to the username that do not work. Learned this the hard way, but your guide above helped me get the framework set up, just had to determine the alternate method to get populated data.

    Like

  • Hi laura,
    I did not know where to send my question in reference to infoPath so I hope you don’t mind.
    We are currently using SharePoint 2010 and Office 2010 for our Intranet. We have a InfoPath from a co-hospital and would like to use the same form. We changed the titles and some rules on the form and now we are starting to the following problem.
    “A view is set up with maybe 10-25 items to view. The next day only the top 5 are still chosen. This has happened each day since Monday after we made some changes to the form.”

    Like

  • Thanks for the post. I am unable to see the User Information List in our Share point site. Is there something that needs to be done to make that visible? Thanks

    Like

  • hi laura,

    I followed all the above steps, but for me output is comming blank, please let me know wat may be the reason

    Like

  • Hi Laura,

    I am getting blank data , when i am publishing the form on office 365, In the preview of infopath everything looks fine but when publishing on office 365 i am getting all blank data, Please help me solve this issue

    Like

  • Hey Laura,

    I’ve been using the UserProfileService to pull in information about the logged in user. Works Peachy! What I would like to do is to look up the same user information for one or more people picker fields on my form.

    I know I am missing something simple here but I just can’t seem to figure it out. Can you point me in the right direction?

    Charles

    Like

  • WKadmin, Yes, it’s different the way you have to do it in Office365 and with SharePoint 2013 because of claims authentication. Lori Gowin wrote a great post here: http://www.pointgowin.com/seethepoint/Lists/Posts/Post.aspx?ID=55

    Karen,
    When you create your data connection, try using the root level of your site collection, instead of a sub-site.

    Chandra,
    I recommend trying to query the user information list, just with no filter, and drop some fields on the form to see if anything comes back at all. Then once you see if there’s data in there, start narrowing it down by querying specific fields. You can test this by dropping all the query fields and all the data fields onto your form so that you can see them all, and create a simple button that just queries that data source to test all this out.

    Hey Charles,
    use the PreferredName field to put it into the display name, and use the AccountInfo field to put it into the Account ID.
    Here’s a post I wrote about that: https://wonderlaura.com/2012/6/27/infopath-pre-populate-the-people-picker

    Like

  • Hi Laura,

    All your infopath tutorials are really awesome. However could you please write an article with screenshots in order to bring up the user information using GetUserProfileBYName in UserProfileService>asmx

    Like

  • I performed these steps exactly and am getting this error:

    An error occurred while trying to connect to a Web service.

    An entry has been added to the Windows event log of the server.
    Log ID:5566

    Correlation ID:29790ce5-50f8-4528-92ea-242db72a5d7e

    Any idea why? Seems like it might be a permissions issue with the base site.

    Like

  • Hi Saurabh,
    Here’s someone who already wrote a blog post about that, with screenshots: http://mackenzie-sharepoint.blogspot.com/2011/11/infopath-2010-using-userprofileservicea.html

    Jordan,
    I recommend trying to navigate directly to the full URL of that web service in the browser, to see if you get an error. Some firewalls cause this.

    Like

  • David McKenzie

    Great post.
    Only problem for me is that I only get the first 30 entries back since going to 2013 (from 2007)
    In 2007 I have been following this technique with the following exception – I have been checking the Retrieve this data box, which you say is very important not to check, but not why.
    I tried creating a new connection with the ‘retrieve’ box unchecked but this did not alter the behavior.
    Either we limit our staff to 30 or I need to find a new approach. I could go the Lori Gowin approach, but would prefer a quick hit at this time so I can focus on the other dozen critical migration issues.
    Thanks

    Like

  • Hi Laura, its really a great article and highly appreciable.
    i have one issue while create data connection for user information list…the User_Name field is not available at all.
    how do i retrieve the username field..is something am i missing?..please help.

    awaiting for your favorable response.

    Best Regards.

    Like

  • Wonderful post. I just have a few question for Laura.

    Could you please specify what timer job that updates the User Information List, and is it possible to create a regular schedule (maybe weekly) for the running of that timer job. If possible, then will the timer job be updating all User Information List in all site collections???

    Quoting Laura:
    “There’s a timer job that updates the user information lists so that they stay accurate when the user profile service does exist. This solution is mostly for people who don’t have the luxury of the UPS. I also already mentioned that people don’t exist in the list until they’ve actually visited the SharePoint site.”

    Like

  • If after publishing the form, the fields never show up, does this mean there is something i missed in your instructions or is the server set up improperly perhaps? If i run a preview in InfoPath, it all works fine.

    I dont have access to do anything with the server. That group is getting everything ready for the 2010 conversion to 2013 and have changed a lot of things. So we can use the GetUserProfile option so I am trying to find other options.

    Like

  • Marie,
    As part of the InfoPath publishing wizard, there is a screen that lets you select which fields you would like to promote to be columns in the SharePoint library. Is that what’s missing, maybe? Just the columns?

    Laura

    Like

  • Thanks for the reply,
    The fields are missing completely from the form itself. In your tests above, it shows the data fields being added to the form then when published, you see the fields and the users information. On my form, none of the fields show up.

    In my previous post, i meant: So we CAN’T use the GetUserProfile option so I am trying to find other options.

    Like

  • Hi Laura,
    I want to add the location(office) filed to the same list but when I use the “Office” from user information web service Im getting a blank field there.
    Also I get a “an error occured while trying to connect to the web service” error when the form is opened online.

    Thanks for a wonderful post!

    Regards,
    Swati

    Like

  • How have I missed this until now??? Great Post! THANK YOU!

    I think I know what Marie’s problem is. When I added the fields from the User Information List to the form, they did NOT show in the Preview until I actually queried the list. Then they popped up.

    Like

  • We use SharePoint Online and it doesn’t appear that Company or Manager are available fields in the User Information List. Is there any workaround to pull that information?

    Like

  • There is an error with this post when it comes to SharePoint 2013. Do not filter on the User Name column (field). Filter on the Account field. So…Account = userName() basically.

    Like

  • Fredrik Coulter

    When I tried to save the data connection, I received the following error message. What do I do now?

    /schema/element[1][@name = ‘myFields’]/complexType[1]/sequence[1][@name = ‘dataFields’]/complexType[1]/element[1][@name = ”]
    A name was started with an invalid character.
    Error parsing ” as NCName datatype.

    On a different note, step ten didn’t have a close button, just a Finish button

    Like

  • We have SharePoint 2013 with Claims Based Authentication. It is not pulling the data on the browser form.

    Like

  • Hi ,

    I have a list and I want , when I select employee name in people picker field other fields like email id and manager name field should be autopopulated on the basis of selected employee name.

    Thanks

    Like

  • Hi Laura,
    first, very compliments for your sharepoint skills and you are very nice girl…..then, thank’s for this walktrought have been very important for me, then i have a request: how can i do to manage multiple Lastname in AD?
    Thank’s in advance.
    Luigi from Italy

    Like

  • I need to get the list of users available in sharepoint group in info path 2013 and bind that collection to textbox with comma separated
    ex:
    In Group A,there are 3 users X,Y,Z.
    If I filter by Group Name “A”, I need to get 3 users bind it in textbox.

    Right now, It is working fine in dropdown,but I don’t know to do for textbox.

    Like

  • Gerry Brimacombe

    Thank you, Wonder Laura Indeed.
    I was struggling how to do this “the easy way”, and the other solutions I found were super complicated.

    The only “gotcha” was the display of the user information PICTURE. It didn’t work at first, but then it did. Not sure what changed, but it’s beautiful now.

    To be clear, you said the content of the User Info List is generated by a user USING THE SITE, right? So new users aren’t in this list until they have logged in at least once?

    Thanks again,
    Gerry@Lightlever.ca

    Like

  • I have the same issue as Fredrik Coulter
    When I tried to save the data connection, I received the following error message. What do I do now?

    /schema/element[1][@name = ‘myFields’]/complexType[1]/sequence[1][@name = ‘dataFields’]/complexType[1]/element[1][@name = ”]
    A name was started with an invalid character.
    Error parsing ” as NCName datatype.
    How was that resolved?
    Thanks

    Like

  • Edson Nascimento

    Wow !
    Thank you very much Laura your step by step works just great for my learning process. Very much appreciated.

    Like

  • I’m still not entirely clear on when the list is updated.

    Is this correct?
    If a user has access to the site via an Active Directory Group then their info will be populated when they access the site.

    Thanks,
    Brian

    Like

  • Sourav Chatterjee

    I followed the steps you mentioned and it worked fine within InfoPath as when I open the preview mode in InfoPath I can see my user information like name ,username etc.However after i published the form and opened the form in SharePoint I just see a blank area with no user information.

    Kindly let me know how the user information be visible in sharepoint

    Like

  • Hi Laura,

    We’re launching SharePoint 2013 at my organization and this blog has been a tremendous resource. As far as the User Information List, I share the frustration of the some others above: I’ve set up everything according to the instructions and when I preview the form in InfoPath, the fields populate as expected. However, once the form is published to SharePoint they do not. Instead, the fields remain blank. I don’t suppose you have any thoughts? Not the end of the world if users have to fill in their own information but getting this going would open up some more possibilities. Thanks a lot!

    Like

  • Hi Laura,

    Many thanks for the great solution, it was the most usefull article in this topic. 🙂

    Like

  • Good morning Laura, I got this working for me but when I published the form and had someone else try it, It populated my data still. Do you know what could cause this?
    Thnx
    Bill

    Like

  • This works for me now in Preview but not when I publish it to my List. Any troubleshooting suggestions?.
    Thnx

    Like

  • Good afternoon Laura,

    Wow, your posts and Power Hours are amazing.
    I just started using InfoPath (yes I know it’s 2015), but I was told that I needed to build a Performance Review without Code, and your blog/powerhour (57) was exactly what I needed.
    I created a dropdown that queries from a list. Based on who the user is (from User Information list), it shows a different drop down (based on criteria from the SharePoint list). I followed you instructions and it worked perfectly in Filler. However, when I published it to SharePoint the entire dropdown showed up.

    I tried what you mentioned earlier (to Jennifer & Chandra), by dropping the entire user information from the User Information List onto the form. Likewise, it shows all of the user information on filler, but none on the SharePoint Form.

    I am using SharePoint 2013 & InfoPath 2013, and am looking forward to your response.

    Thank you,
    Shlomo

    Like

  • Hey Laura….Thanks for the write up.

    I have the same issue as Bill above. I can view the information in preview mode in Infopath, but when I publish the form, and open a new entry, all of the fields are blank. Trying to do some troubleshooting, hoping you know the quick route to resolution.

    Bill….if you figured this one out, would love your feedback.

    Thx,

    Like

  • Hi Laura,

    I’ve watched a few of your videos on YouTube and read a few blogs – very good stuff.

    This will be difficult to articulate… I’m having issues with the form working once it’s in Sharepoint.

    I’ve done tons of research and it seems to be a common problem people have experienced. Everything works fine during preview mode but not after publishing. I get various errors. One of the biggest errors was the whole data connection (DC) not working. I received a solution from our Sharepoint Team which involved converting the DC to a UDC file and then modifying the part and entering INFOPASS as the Appid and NTLM as the CredentialType. This worked perfect in Sharepoint, until I went away for a break came back to my PC being frozen so I had to force shut down, went back to my site and the form was broken again. I’m worried it may have been corrupted somehow, so I started from scratch again (deleted everything including form library, data connections, udc files, etc). After recreating all of the data connections (getUserProfileByName & getCommonManager), converted them to udc files and now I get the same error I got at the start. It’s obviously quite difficult to articulate but i’m hoping you might have some kind of suggestions from other similar experiences to at least point me in the right direction as I’ve had no luck for the past week on my own.

    I just watched a great video about InfoPath Best Practices and one of the things that was mentioned that concerns me is when you start making big changes after the form was published you risk breaking the form – I’ve made significant changes to my form prior to all of these issues – could this be part of the problem. I somehow think it isn’t solely on the basis that I did manage to get the form working perfect after the udc file editing – of course this was right before my PC decided to be a total prick and corrupt my form progress.
    Link: https://www.youtube.com/watch?v=J6IoDMU0Hkg

    my twitter is @nathanpiahana

    Hopefully I have explained this good enough for you to grasp where I need to focus my efforts on finding a solution.

    Like

  • Hi, all of you who are mentioning that it works in preview but not when you publish it, that’s going to be because of the syntax difference with claims based authentication. Check out the video in here, where I address that syntax difference https://wonderlaura.com/2012/06/27/infopath-pre-populate-the-people-picker/

    Like

  • Will it work with SharePoint Online ?

    Like

  • Peter Martensen

    I watched your video and read Lori’s blog. My SP Admin is having trouble finding the General Application Settings>Configure InfoPath Forms Services in Central Administration in Office 365 / SP Online. Can you tell me where to find that?

    Like

  • Hi!
    Can I use it for get information of custom user – from “users and group” columns.

    and thanks 🙂

    Like

  • Hi Laura,

    Is there a way to use the user information to be able to auto populate InfoPath forms? I am using a InfoPath 2013 list from. I would like to create a last user record button to pull in the data from a secondary source from my main list for the last record entered by a user. I have tried this with the Created by field, but have not had any luck trying to connect this to a list ID to set certain fields.

    Thanks,

    Ross

    Like

    • NVM, I figured it out. The issue was my query filter. I needed to set that value to the ID and then filter for user.

      Like

  • Hi Laura,

    I have this working on one site but not another, it always pulls my name and info instead of the user that is logged onto the site.
    Any ideas?

    Like

  • Can you tell us more about this? I’d love to find out more details.

    Like

  • Thanks for this amazing post! I’m trying to feed the identity of the user into a person/group column and can’t find out how to do so. Would you be able to assist me here? Thanks,
    Frank

    Like

  • Hi Laura, thanks a lot for this wicked post. I can’t believe I survived without this. I was having the issue where all data would show up without a problem in Preview, but return blank on the SP site. I watched your video but it’s slightly different from the approach you are trying to get at in this post.

    I realized, however, after troubleshooting like you indicating using a query data connection button and displaying all the fields on the form, that my problem was this i:0#.w|domain\ . By default my query button was going for this string plus my user account name so I tried removing that from the text field and leaving only “dgarth200” and it return values perfectly. Then I set up a set field value rule in infopath (substring-after(userName(), “\”) that would strip the unwanted piece of the string out and now it works like a charm in sharepoint.

    Thanks again for all your help

    Like

Leave a reply or question

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s